We're a little crazy, about science!

A snag

No tears, please. It’s a waste of good suffering.

You know… that’s how it goes sometimes. You’re cruising along and everything looks great then, BAM! Totally derailed. What happened? Turns out I have a problem with my data. Not a problem persay, more like an anomaly, one that throws a rather large wrench into what WAS a perfectly running operation. Things were looking good, but now… I have a doubt.

If you had asked me before yesterday I would’ve told you that I was incredibly confident that my technique worked. We found exactly what I expected to find almost exclusively exactly where we would expect to find it. We also found that what we had didn’t happen in the places where it should definitely not happen, a good sign that we were on to something. I was doing great and everything I threw at the data to confirm this was giving me back more and more evidence to support my claim. Then yesterday happened.

Let’s just cut to the end, I have no lag in my data, as in none. When recording from the brain, the muscles, anywhere there should be a delay. Depending on what you’re doing that delay could be 1ms it could be as high as 30ms, but there is ALWAYS a delay because nerve signals are not instantaneously transmitted. Now I’m not positive I have a problem, but I’m no longer confident that there isn’t one either.

I was comparing results from two physically separate locations on the brain, distant enough that we should see a slight lag if one signal drives the other, we should see nothing if there is no relation between the two. If there is no correlation between the two signals if one changes nothing should happen with the other so there would no correlation and the lag would be arbitrary, usually some huge value that is meaningless.

My problem isn’t that I have no correlation, it’s that my signals are almost perfectly correlated and have zero lag. That’s not possible. What’s more confusing is they are certainly not the same signal, I don’t believe I made an error somewhere and when I check the control condition I find the signal lag I would expect to see…. so what the fuck?

I’m fairly confident I may be the problem. As in I set something wrong in my calculation to cause the issue or maybe… just maybe… something else was wrong with the way I processed the data? The other issue is the signals are definitely not the same. The spectral content, that is to say the frequencies that make up the signals, are very different from the two locations I’m looking at, but when I plot the amplitude responses they look remarkably similar to one another and there appears to be zero lag from a visual inspection.

So what to do now? Well we scrap all the processed data and start from the raw data I have. I’ll run through my code again and make sure I didn’t make a mistake somewhere. There is one area that was different from my qualifying exam pipeline, a new algorithm I use to remove line noise from the data without having to just ignore the frequency range (or notch filter which leaves that area useless anyway). I’m wondering if that could’ve introduced some sort of artifact into the data that could be causing the problem.

In any case, this is why we check our data! It’s also why we’re still being cautiously optimistic about my new method. There’s still just so much we don’t know and there isn’t a whole lot of human data to help me make sense of what I’m seeing so a lot of this is just me trying to make sense of it without a ton of evidence to back it up.

The takeaway for today’s post? It’s never a bad thing to think outside of the box, just make sure you’ve checked everything before you share it with others. I would hate to let my project out into the world only to find out it’s just noise.

But enough about us, what about you?

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s

This site uses Akismet to reduce spam. Learn how your comment data is processed.